KB000010

AIMMS Knowledge Base Article – KB000010

 

“License Expired Node Lock” while there is a dongle

The information in this article applies to AIMMS 3.5 and higher versions.

 

Summary

When AIMMS finds a node lock, it will not look for a dongle. Therefore, an invalid node lock has to be removed prior to using a dongle for the same license.

Symptoms

You used to have a node lock for your AIMMS license, but now you installed a security dongle for this same license, because the node lock is expired. You startup AIMMS with the security dongle, and the license configuration dialog appears. At the left you can see the node lock license with status ‘Invalid’ and at the right (License protection) you can see ‘Expired (please try Update)’.

Cause

When AIMMS is started and it finds a node lock (valid or invalid) for a specific license number it will not look for the AIMMS dongle.

Resolution

Remove the node lock in the following way:

  1. Open AIMMS (It will show the License Configuration dialog, as there is no valid license)
  2. Select the license with the expired node lock
  3. Hit the “Deactivation” button in this window and follow the instructions in the windows
  4. Close the License Configuration dialog by clicking on the “Cancel” button
  5. Remove the following two files
     

    • C:\Documents and Settings\All Users\Application Data\Paragon Decision Technology\Node locks\.lock
    • C:\Documents and Settings\All Users\Application Data\Paragon Decision Technology\Node locks\.ver
  6. Open AIMMS

Now AIMMS should start without any problem, AIMMS will look for the dongle, as there is no node lock file present

More information

For more information, please contact us at support@aimms.com  

 

 

Last reviewed: 09-02-2006